魔兽世界之一:备战

题目链接

描述

魔兽世界的西面是红魔军的司令部,东面是蓝魔军的司令部。两个司令部之间是依次排列的若干城市。红司令部,City 1,City 2,……,City n,蓝司令部 两军的司令部都会制造武士。

武士一共有 dragon 、ninja、iceman、lion、wolf 五种。每种武士都有编号、生命值、攻击力这三种属性。

双方的武士编号都是从1开始计算。红方制造出来的第n个武士,编号就是n。同样,蓝方制造出来的第n个武士,编号也是n。

武士在刚降生的时候有一个生命值。

在每个整点,双方的司令部中各有一个武士降生。

红方司令部按照iceman、lion、wolf、ninja、dragon的顺序循环制造武士。

蓝方司令部按照lion、dragon、ninja、iceman、wolf的顺序循环制造武士。

制造武士需要生命元。

制造一个初始生命值为m的武士,司令部中的生命元就要减少m个。

如果司令部中的生命元不足以制造某个按顺序应该制造的武士,那么司令部就试图制造下一个。如果所有武士都不能制造了,则司令部停止制造武士。

给定一个时间,和双方司令部的初始生命元数目,要求你将从0点0分开始到双方司令部停止制造武士为止的所有事件按顺序输出。一共有两种事件,其对应的输出样例如下:

  1. 武士降生输出样例: 004 blue lion 5 born with strength 5,2 lion in red headquarter表示在4点整,编号为5的蓝魔lion武士降生,它降生时生命值为5,降生后蓝魔司令部里共有2个lion武士。(为简单起见,不考虑单词的复数形式)注意,每制造出一个新的武士,都要输出此时司令部里共有多少个该种武士。
  2. 司令部停止制造武士输出样例: 010 red headquarter stops making warriors表示在10点整,红方司令部停止制造武士

输出事件时:

  • 首先按时间顺序输出;
  • 同一时间发生的事件,先输出红司令部的,再输出蓝司令部的。

输入

第一行是一个整数,代表测试数据组数。

每组测试数据共两行。

第一行:一个整数M。其含义为, 每个司令部一开始都有M个生命元( 1 <= M <= 10000)。

第二行:五个整数,依次是 dragon 、ninja、iceman、lion、wolf 的初始生命值。它们都大于0小于等于10000。

输出

对每组测试数据,要求输出从0时0分开始,到双方司令部都停止制造武士为止的所有事件。对每组测试数据,首先输出"Case:n" n是测试数据的编号,从1开始 。接下来按恰当的顺序和格式输出所有事件。每个事件都以事件发生的时间开头,时间以小时为单位,有三位。

样例输入

1

20

3 4 5 6 7

样例输出

Case:1
000 red iceman 1 born with strength 5,1 iceman in red headquarter
000 blue lion 1 born with strength 6,1 lion in blue headquarter
001 red lion 2 born with strength 6,1 lion in red headquarter
001 blue dragon 2 born with strength 3,1 dragon in blue headquarter
002 red wolf 3 born with strength 7,1 wolf in red headquarter
002 blue ninja 3 born with strength 4,1 ninja in blue headquarter
003 red headquarter stops making warriors
003 blue iceman 4 born with strength 5,1 iceman in blue headquarter
004 blue headquarter stops making warriors

思路:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
#include <iostream>
#include <cstdio>
using namespace std;
const int WARRIOR_NUM = 5;

class Headquarter;
class Warrior{
private:
Headquarter * pHeadquarter;
int kindNo;//武士种类编号 d,n,i,l,w
int no;
public:
static string names[WARRIOR_NUM];//武士名
static int initialLifeValue[WARRIOR_NUM];//武士生命值
Warrior(Headquarter *p, int no_, int kindNo_);//初始化
void PrintResult(int nTime);//输出结果
};

class Headquarter{
private:
int totalLifeValue;//总的生命值
bool stopped;
int totalWarriorNum;//总的武士数目
int color;//红还是蓝
int curMakingSeqIdx;//当前要制造的武士是制造序列中的第几个
int warriorNum[WARRIOR_NUM];
Warrior *pWarrior[1000];
public:
friend class Warrior;
static int makingSeq[2][WARRIOR_NUM];//武士的制造序列,0为红,1为蓝
void Init(int color_,int Lv);//初始化
~Headquarter();//析构
int Produce(int nTime);
string GetColor();
};

Warrior::Warrior(Headquarter *p, int no_, int kindNo_)//构造函数
{
no = no_;
kindNo = kindNo_;
pHeadquarter = p;
}

void Warrior::PrintResult(int nTime)
{
string color = pHeadquarter->GetColor();
printf("%03d %s %s %d born with strength %d,%d %s in %s headquarter\n" ,
nTime, color.c_str(), names[kindNo].c_str(), no, initialLifeValue[kindNo],
pHeadquarter->warriorNum[kindNo],names[kindNo].c_str(),color.c_str());
}

void Headquarter::Init(int color_,int Lv)
{
color = color_;
totalLifeValue = Lv;//初始化生命值
totalWarriorNum = 0;//刚开始时,武士数量为0
stopped = false;
curMakingSeqIdx = 0;//还没开始制造
for(int i=0;i<WARRIOR_NUM;i++)
warriorNum[i]=0;
}

Headquarter::~Headquarter()//析构
{
for(int i=0;i<totalWarriorNum;i++)
delete pWarrior[i];
}

int Headquarter::Produce(int nTime)
{
if(stopped) return 0;
int searchingTimes = 0;
while(Warrior::initialLifeValue[makingSeq[color][curMakingSeqIdx]] > totalLifeValue
&& searchingTimes < WARRIOR_NUM) {
curMakingSeqIdx = (curMakingSeqIdx+1) % WARRIOR_NUM;//制造武士的序列,5个以后,返回到最开始
searchingTimes++;
}
int kindNo = makingSeq[color][curMakingSeqIdx];//武士制造序列
if(Warrior::initialLifeValue[kindNo] > totalLifeValue) {//生命元不够制造武士
stopped = true;
if (color == 0) printf("%03d red headquarter stops making warriors\n",nTime);
else printf("%03d blue headquarter stops making warriors\n",nTime);
return 0;
}
//制造士兵
totalLifeValue -= Warrior::initialLifeValue[kindNo];//每制造一个武士,就减去制造该武士的生命元
curMakingSeqIdx = (curMakingSeqIdx+1) % WARRIOR_NUM;
pWarrior[totalWarriorNum] = new Warrior(this,totalWarriorNum+1,kindNo);//构造下一个武士
warriorNum[kindNo]++;//该武士的数目加1
pWarrior[totalWarriorNum]->PrintResult(nTime);//输出该次制造武士的结果
totalWarriorNum++;
return 1;
}

string Headquarter::GetColor()
{
if (color==0)
return "red";
else return "blue";
}

string Warrior::names[WARRIOR_NUM] = {"dragon","ninja","iceman","lion","wolf"};//初始顺序
int Warrior::initialLifeValue[WARRIOR_NUM];
int Headquarter::makingSeq[2][WARRIOR_NUM] = {{2,3,4,1,0},{3,0,1,2,4}};//红蓝制作武士的顺序

int main()
{
int t,m;
Headquarter RedHead,BlueHead;
cin >> t;
int nCaseNo=1;
while(t--){
cout<<"Case:"<<nCaseNo++<<endl;
cin >> m;
for(int i=0;i<WARRIOR_NUM;i++)
cin>>Warrior::initialLifeValue[i];//初始化生命值
RedHead.Init(0,m);//0为红
BlueHead.Init(1,m);
int nTime=0;//时间
while(1){
int temp1 = RedHead.Produce(nTime);
int temp2 = BlueHead.Produce(nTime);
if(temp1 == 0 && temp2 == 0)
break;
nTime++;
}
}
return 0;
}